$re = '/(?<!\S)(inn)|([^aeiou\r\n])\2+/';
$str = 'asso
assso
assocco
innasso
inninnasso';
$subst = "$1$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;