package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[^,]*(,\s*другой,)`)
var str = `различный, разный, другой, отличный от, необычный, неодинаковый, непохожий, не такой
втор ой, другой, второй, секунда, вторым номером, подкреплять
тут может быть любое количество слов главное чтобы до запятой, другой, второй, секунда, подкреплять
другой, остальные, иной, другой, иначе`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}