const regex = /^[^,]*(,\s*другой,)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[^,]*(,\\s*другой,)', 'gm')
const str = `различный, разный, другой, отличный от, необычный, неодинаковый, непохожий, не такой
втор ой, другой, второй, секунда, вторым номером, подкреплять
тут может быть любое количество слов главное чтобы до запятой, другой, второй, секунда, подкреплять
другой, остальные, иной, другой, иначе`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}