import re
regex = re.compile(r"^[^,]*(,\s*другой,)", flags=re.MULTILINE)
test_str = ("различный, разный, другой, отличный от, необычный, неодинаковый, непохожий, не такой\n"
"втор ой, другой, второй, секунда, вторым номером, подкреплять\n"
"тут может быть любое количество слов главное чтобы до запятой, другой, второй, секунда, подкреплять\n"
"другой, остальные, иной, другой, иначе")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")