import Foundation
let pattern = #"^[^,]*(,\s*другой,)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
различный, разный, другой, отличный от, необычный, неодинаковый, непохожий, не такой
втор ой, другой, второй, секунда, вторым номером, подкреплять
тут может быть любое количество слов главное чтобы до запятой, другой, второй, секунда, подкреплять
другой, остальные, иной, другой, иначе
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)