#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)\b0[0-9]{9,10}\D"
Local $sString = "Đây là số di động 0902209011" & @CRLF & _
"0902209012 cũng là số di động" & @CRLF & _
"091355466677 không phải di động vì nó quá dài" & @CRLF & _
"1234567890 không phải di động vì không có số 0 ở đầu" & @CRLF & _
"0123456789 có số 0 ở đầu" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")