const regex = /\b0[0-9]{9,10}\D/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b0[0-9]{9,10}\\D', 'gmi')
const str = `Đây là số di động 0902209011
0902209012 cũng là số di động
091355466677 không phải di động vì nó quá dài
1234567890 không phải di động vì không có số 0 ở đầu
0123456789 có số 0 ở đầu
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}