use strict;
my $str = 'Đây là số di động 0902209011
0902209012 cũng là số di động
091355466677 không phải di động vì nó quá dài
1234567890 không phải di động vì không có số 0 ở đầu
0123456789 có số 0 ở đầu
';
my $regex = qr/\b0[0-9]{9,10}\D/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}