using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b0[0-9]{9,10}\D";
string input = @"Đây là số di động 0902209011
0902209012 cũng là số di động
091355466677 không phải di động vì nó quá dài
1234567890 không phải di động vì không có số 0 ở đầu
0123456789 có số 0 ở đầu
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}