package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)\b0[0-9]{9,10}\D`)
var str = `Đây là số di động 0902209011
0902209012 cũng là số di động
091355466677 không phải di động vì nó quá dài
1234567890 không phải di động vì không có số 0 ở đầu
0123456789 có số 0 ở đầu
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}