import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b0[0-9]{9,10}\\D";
final String string = "Đây là số di động 0902209011\n"
+ "0902209012 cũng là số di động\n"
+ "091355466677 không phải di động vì nó quá dài\n"
+ "1234567890 không phải di động vì không có số 0 ở đầu\n"
+ "0123456789 có số 0 ở đầu\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}