# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([(][{}a-zA-Z0-9,()]+,[{}a-zA-Z0-9,]+),/(\g<1>),/gm;t' <<< "Should work for:
(1,2,3)
(1,2,3,4)
((1,2),3,4)
({x},{y},{z})
(1,(2,3),4)
Should not work for:
(1,2)
(10,10)
(1,10)
((1,2),3)
(((1,1),1),1)
({0},1)
({{x},{x,y}},z)"