using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([(][{}a-zA-Z0-9,()]+,[{}a-zA-Z0-9,]+),";
string substitution = @"(\g<1>),";
string input = @"Should work for:
(1,2,3)
(1,2,3,4)
((1,2),3,4)
({x},{y},{z})
(1,(2,3),4)
Should not work for:
(1,2)
(10,10)
(1,10)
((1,2),3)
(((1,1),1),1)
({0},1)
({{x},{x,y}},z)";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}