// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([(][{}a-zA-Z0-9,()]+,[{}a-zA-Z0-9,]+),").unwrap();
let string = "Should work for:
(1,2,3)
(1,2,3,4)
((1,2),3,4)
({x},{y},{z})
(1,(2,3),4)
Should not work for:
(1,2)
(10,10)
(1,10)
((1,2),3)
(((1,1),1),1)
({0},1)
({{x},{x,y}},z)";
let substitution = "(\\g<1>),";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}