#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)([(][{}a-zA-Z0-9,()]+,[{}a-zA-Z0-9,]+),"
Local $sString = "Should work for:" & @CRLF & _
"(1,2,3)" & @CRLF & _
"(1,2,3,4)" & @CRLF & _
"((1,2),3,4)" & @CRLF & _
"({x},{y},{z})" & @CRLF & _
"(1,(2,3),4)" & @CRLF & _
"" & @CRLF & _
"Should not work for:" & @CRLF & _
"(1,2)" & @CRLF & _
"(10,10)" & @CRLF & _
"(1,10)" & @CRLF & _
"((1,2),3)" & @CRLF & _
"(((1,1),1),1)" & @CRLF & _
"({0},1)" & @CRLF & _
"({{x},{x,y}},z)"
Local $sSubst = "(\g<1>),"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)