use strict;
my $str = 'Should work for:
(1,2,3)
(1,2,3,4)
((1,2),3,4)
({x},{y},{z})
(1,(2,3),4)
Should not work for:
(1,2)
(10,10)
(1,10)
((1,2),3)
(((1,1),1),1)
({0},1)
({{x},{x,y}},z)';
my $regex = qr/([(][{}a-zA-Z0-9,()]+,[{}a-zA-Z0-9,]+),/mp;
my $subst = '(\\g<1>),';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";