$re = '/([(][{}a-zA-Z0-9,()]+,[{}a-zA-Z0-9,]+),/m';
$str = 'Should work for:
(1,2,3)
(1,2,3,4)
((1,2),3,4)
({x},{y},{z})
(1,(2,3),4)
Should not work for:
(1,2)
(10,10)
(1,10)
((1,2),3)
(((1,1),1),1)
({0},1)
({{x},{x,y}},z)';
$subst = "(\g<1>),";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;