#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(?<=^|\W)\s?>(.+)(?:\n|$)"
Local $sString = "<!-- react-text: 44642 --><test> test" & @CRLF & _
">Test" & @CRLF & _
"test: <Minecraft> <u>MRVDOG</u> >Joined!" & @CRLF & _
"<Minecraft> <u>MRVDOG</u> Joined!" & @CRLF & _
">Test" & @CRLF & _
"<test> test" & @CRLF & _
"test >test" & @CRLF & _
"<!-- /react-text -->" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"<!-- react-text: 44642 -->> test" & @CRLF & _
"<Minecraft> <u>MRVDOG</u> Joined!" & @CRLF & _
"<!-- /react-text -->" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"<!-- react-text: 44642 --><Minecraft> <u>MRVDOG</u> Joined!" & @CRLF & _
"<!-- /react-text -->" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"<!-- react-text: 44642 -->" & @CRLF & _
"```<div>test</div>```" & @CRLF & _
"<!-- /react-text -->"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")