import Foundation
let pattern = #"(?<=^|\W)\s?>(.+)(?:\n|$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
<!-- react-text: 44642 --><test> test
>Test
test: <Minecraft> <u>MRVDOG</u> >Joined!
<Minecraft> <u>MRVDOG</u> Joined!
>Test
<test> test
test >test
<!-- /react-text -->
<!-- react-text: 44642 -->> test
<Minecraft> <u>MRVDOG</u> Joined!
<!-- /react-text -->
<!-- react-text: 44642 --><Minecraft> <u>MRVDOG</u> Joined!
<!-- /react-text -->
<!-- react-text: 44642 -->
```<div>test</div>```
<!-- /react-text -->
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)