$re = '`(?<=^|\W)\s?>(.+)(?:\n|$)`mi';
$str = '<!-- react-text: 44642 --><test> test
>Test
test: <Minecraft> <u>MRVDOG</u> >Joined!
<Minecraft> <u>MRVDOG</u> Joined!
>Test
<test> test
test >test
<!-- /react-text -->
<!-- react-text: 44642 -->> test
<Minecraft> <u>MRVDOG</u> Joined!
<!-- /react-text -->
<!-- react-text: 44642 --><Minecraft> <u>MRVDOG</u> Joined!
<!-- /react-text -->
<!-- react-text: 44642 -->
```<div>test</div>```
<!-- /react-text -->';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);