using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=^|\W)\s?>(.+)(?:\n|$)";
string input = @"<!-- react-text: 44642 --><test> test
>Test
test: <Minecraft> <u>MRVDOG</u> >Joined!
<Minecraft> <u>MRVDOG</u> Joined!
>Test
<test> test
test >test
<!-- /react-text -->
<!-- react-text: 44642 -->> test
<Minecraft> <u>MRVDOG</u> Joined!
<!-- /react-text -->
<!-- react-text: 44642 --><Minecraft> <u>MRVDOG</u> Joined!
<!-- /react-text -->
<!-- react-text: 44642 -->
```<div>test</div>```
<!-- /react-text -->";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}