use strict;
my $str = '<!-- react-text: 44642 --><test> test
>Test
test: <Minecraft> <u>MRVDOG</u> >Joined!
<Minecraft> <u>MRVDOG</u> Joined!
>Test
<test> test
test >test
<!-- /react-text -->
<!-- react-text: 44642 -->> test
<Minecraft> <u>MRVDOG</u> Joined!
<!-- /react-text -->
<!-- react-text: 44642 --><Minecraft> <u>MRVDOG</u> Joined!
<!-- /react-text -->
<!-- react-text: 44642 -->
```<div>test</div>```
<!-- /react-text -->';
my $regex = qr`(?<=^|\W)\s?>(.+)(?:\n|$)`mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}