const regex = new RegExp('(?<=^|\\W)\\s?>(.+)(?:\\n|$)', 'gmi')
const str = `<!-- react-text: 44642 --><test> test
>Test
test: <Minecraft> <u>MRVDOG</u> >Joined!
<Minecraft> <u>MRVDOG</u> Joined!
>Test
<test> test
test >test
<!-- /react-text -->
<!-- react-text: 44642 -->> test
<Minecraft> <u>MRVDOG</u> Joined!
<!-- /react-text -->
<!-- react-text: 44642 --><Minecraft> <u>MRVDOG</u> Joined!
<!-- /react-text -->
<!-- react-text: 44642 -->
\`\`\`<div>test</div>\`\`\`
<!-- /react-text -->`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}