use strict;
my $str = '{
area: {
"lang": "en",
"area": "25",
"region": "mea"
},
config: {
"rtl": false,
"breakpoint": 768
}
}';
my $regex = qr/([^"\s]+)+: ?{/mp;
my $subst = '"$1": {';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";