#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(gfycat\.com\/(?:\w*\/)*)(\w+)"
Local $sString = "gfycat.com/enlightenedpleasedliger" & @CRLF & _
"gfycat.com/ko/enlightenedpleasedliger" & @CRLF & _
"gfycat.com/ko/EnlightenedPleasedLiger" & @CRLF & _
"https://gfycat.com/EnlightenedPleasedLiger" & @CRLF & _
"https://gfycat.com/ko/EnlightenedPleasedLiger" & @CRLF & _
"https://gfycat.com/ifr/EnlightenedPleasedLiger" & @CRLF & _
"gfycat.com/ifr/EnlightenedPleasedLiger" & @CRLF & _
"https://thumbs.gfycat.com/EnlightenedPleasedLiger-mobile.mp4"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")