import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(gfycat\\.com\\/(?:\\w*\\/)*)(\\w+)";
final String string = "gfycat.com/enlightenedpleasedliger\n"
+ "gfycat.com/ko/enlightenedpleasedliger\n"
+ "gfycat.com/ko/EnlightenedPleasedLiger\n"
+ "https://gfycat.com/EnlightenedPleasedLiger\n"
+ "https://gfycat.com/ko/EnlightenedPleasedLiger\n"
+ "https://gfycat.com/ifr/EnlightenedPleasedLiger\n"
+ "gfycat.com/ifr/EnlightenedPleasedLiger\n"
+ "https://thumbs.gfycat.com/EnlightenedPleasedLiger-mobile.mp4";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}