$re = '/(gfycat\.com\/(?:\w*\/)*)(\w+)/m';
$str = 'gfycat.com/enlightenedpleasedliger
gfycat.com/ko/enlightenedpleasedliger
gfycat.com/ko/EnlightenedPleasedLiger
https://gfycat.com/EnlightenedPleasedLiger
https://gfycat.com/ko/EnlightenedPleasedLiger
https://gfycat.com/ifr/EnlightenedPleasedLiger
gfycat.com/ifr/EnlightenedPleasedLiger
https://thumbs.gfycat.com/EnlightenedPleasedLiger-mobile.mp4';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);