import Foundation
let pattern = #"(gfycat\.com\/(?:\w*\/)*)(\w+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
gfycat.com/enlightenedpleasedliger
gfycat.com/ko/enlightenedpleasedliger
gfycat.com/ko/EnlightenedPleasedLiger
https://gfycat.com/EnlightenedPleasedLiger
https://gfycat.com/ko/EnlightenedPleasedLiger
https://gfycat.com/ifr/EnlightenedPleasedLiger
gfycat.com/ifr/EnlightenedPleasedLiger
https://thumbs.gfycat.com/EnlightenedPleasedLiger-mobile.mp4
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)