package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(gfycat\.com\/(?:\w*\/)*)(\w+)`)
var str = `gfycat.com/enlightenedpleasedliger
gfycat.com/ko/enlightenedpleasedliger
gfycat.com/ko/EnlightenedPleasedLiger
https://gfycat.com/EnlightenedPleasedLiger
https://gfycat.com/ko/EnlightenedPleasedLiger
https://gfycat.com/ifr/EnlightenedPleasedLiger
gfycat.com/ifr/EnlightenedPleasedLiger
https://thumbs.gfycat.com/EnlightenedPleasedLiger-mobile.mp4`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}