using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(gfycat\.com\/(?:\w*\/)*)(\w+)";
string input = @"gfycat.com/enlightenedpleasedliger
gfycat.com/ko/enlightenedpleasedliger
gfycat.com/ko/EnlightenedPleasedLiger
https://gfycat.com/EnlightenedPleasedLiger
https://gfycat.com/ko/EnlightenedPleasedLiger
https://gfycat.com/ifr/EnlightenedPleasedLiger
gfycat.com/ifr/EnlightenedPleasedLiger
https://thumbs.gfycat.com/EnlightenedPleasedLiger-mobile.mp4";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}