# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^((?:[^_]*_){2})[^_]*/$1/g;t' <<< "A_B_C_D_E"