using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((?:[^_]*_){2})[^_]*";
string substitution = @"$1";
string input = @"A_B_C_D_E";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}