use strict;
my $str = 'A_B_C_D_E';
my $regex = qr/^((?:[^_]*_){2})[^_]*/p;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";