import Foundation
let pattern = #"^((?:[^_]*_){2})[^_]*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"A_B_C_D_E"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)