#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "^((?:[^_]*_){2})[^_]*"
Local $sString = "A_B_C_D_E"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)