#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\b[a-zA-Z_][a-zA-Z0-9_]*\(.*)(?:\b[a-zA-Z_][a-zA-Z0-9_]*)?(\b[a-zA-Z_][a-zA-Z0-9_]*\(.+?\))(.+)"
Local $sString = "function(1, 2, 3)" & @CRLF & _
"function(1, 2, 3, 4)" & @CRLF & _
"function(1, function(1, 2), 3)" & @CRLF & _
"function(function(function(1, 2), 2), 2, 3, 4)" & @CRLF & _
"function(1, 2)" & @CRLF & _
"function(1, function(1, function(1, 2)))" & @CRLF & _
"function(1, function(function(1), 2))"
Local $sSubst = "\1-\3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)