// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\b[a-zA-Z_][a-zA-Z0-9_]*\(.*)(?:\b[a-zA-Z_][a-zA-Z0-9_]*)?(\b[a-zA-Z_][a-zA-Z0-9_]*\(.+?\))(.+)").unwrap();
let string = "function(1, 2, 3)
function(1, 2, 3, 4)
function(1, function(1, 2), 3)
function(function(function(1, 2), 2), 2, 3, 4)
function(1, 2)
function(1, function(1, function(1, 2)))
function(1, function(function(1), 2))";
let substitution = "\\1-\\3";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}