import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\b[a-zA-Z_][a-zA-Z0-9_]*\\(.*)(?:\\b[a-zA-Z_][a-zA-Z0-9_]*)?(\\b[a-zA-Z_][a-zA-Z0-9_]*\\(.+?\\))(.+)";
final String string = "function(1, 2, 3)\n"
+ "function(1, 2, 3, 4)\n"
+ "function(1, function(1, 2), 3)\n"
+ "function(function(function(1, 2), 2), 2, 3, 4)\n"
+ "function(1, 2)\n"
+ "function(1, function(1, function(1, 2)))\n"
+ "function(1, function(function(1), 2))";
final String subst = "\\1-\\3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}