package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\b[a-zA-Z_][a-zA-Z0-9_]*\(.*)(?:\b[a-zA-Z_][a-zA-Z0-9_]*)?(\b[a-zA-Z_][a-zA-Z0-9_]*\(.+?\))(.+)`)
var str = `function(1, 2, 3)
function(1, 2, 3, 4)
function(1, function(1, 2), 3)
function(function(function(1, 2), 2), 2, 3, 4)
function(1, 2)
function(1, function(1, function(1, 2)))
function(1, function(function(1), 2))`
var substitution = "\1-\3"
fmt.Println(re.ReplaceAllString(str, substitution))
}