# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\b[a-zA-Z_][a-zA-Z0-9_]*\(.*)(?:\b[a-zA-Z_][a-zA-Z0-9_]*)?(\b[a-zA-Z_][a-zA-Z0-9_]*\(.+?\))(.+)"
test_str = ("function(1, 2, 3)\n"
"function(1, 2, 3, 4)\n"
"function(1, function(1, 2), 3)\n"
"function(function(function(1, 2), 2), 2, 3, 4)\n"
"function(1, 2)\n"
"function(1, function(1, function(1, 2)))\n"
"function(1, function(function(1), 2))")
subst = "\\1-\\3"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.