$re = '/(\b[a-zA-Z_][a-zA-Z0-9_]*\(.*)(?:\b[a-zA-Z_][a-zA-Z0-9_]*)?(\b[a-zA-Z_][a-zA-Z0-9_]*\(.+?\))(.+)/m';
$str = 'function(1, 2, 3)
function(1, 2, 3, 4)
function(1, function(1, 2), 3)
function(function(function(1, 2), 2), 2, 3, 4)
function(1, 2)
function(1, function(1, function(1, 2)))
function(1, function(function(1), 2))';
$subst = "\1-\3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;