using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"array$[\t\n\r\s]*?\([\t\s]*?$";
string input = @"text array
text
text array
(
text array(
(
text array
(
text
text array
(
text
text (array
(
array
text array
(
text";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}