$re = '/array$[\t\n\r\s]*?\([\t\s]*?$/m';
$str = 'text array
text
text array
(
text array(
(
text array
(
text
text array
(
text
text (array
(
array
text array
(
text';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);