package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)array$[\t\n\r\s]*?\([\t\s]*?$`)
var str = `text array
text
text array
(
text array(
(
text array
(
text
text array
(
text
text (array
(
array
text array
(
text`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}