re = /array$[\t\n\r\s]*?\([\t\s]*?$/m
str = 'text array
text
text array
(
text array(
(
text array
(
text
text array
(
text
text (array
(
array
text array
(
text'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end