import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "array$[\\t\\n\\r\\s]*?\\([\\t\\s]*?$";
final String string = "text array\n"
+ "text\n"
+ "text array\n"
+ " (\n"
+ "text array(\n"
+ " (\n"
+ "text array\n"
+ "(\n"
+ "text\n"
+ "text array\n"
+ " ( \n"
+ "text\n"
+ "text (array\n"
+ " (\n"
+ "array\n"
+ "text array\n"
+ " (\n"
+ "text";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}