// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)array$[\t\n\r\s]*?\([\t\s]*?$").unwrap();
let string = "text array
text
text array
(
text array(
(
text array
(
text
text array
(
text
text (array
(
array
text array
(
text";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}