#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:index|home|main)(?:[\.\/](?:php|html?|\/?))?$"
Local $sString = "http://bouquet-delivery.ru/index.php" & @CRLF & _
"http://bouquet-delivery.ru/home" & @CRLF & _
"http://bouquet-delivery.ru/home/" & @CRLF & _
"http://www.bouquet-delivery.ru/" & @CRLF & _
"http://www.bouquet-delivery.ru/index.php" & @CRLF & _
"http://www.bouquet-delivery.ru/index.html" & @CRLF & _
"http://www.bouquet-delivery.ru/index.htm" & @CRLF & _
"http://www.bouquet-delivery.ru/index/" & @CRLF & _
"http://www.bouquet-delivery.ru/home" & @CRLF & _
"http://www.bouquet-delivery.ru/home/" & @CRLF & _
"http://www.bouquet-delivery.ru/home.php" & @CRLF & _
"http://www.bouquet-delivery.ru/home.html" & @CRLF & _
"http://www.bouquet-delivery.ru/home.htm" & @CRLF & _
"http://www.bouquet-delivery.ru/main" & @CRLF & _
"http://www.bouquet-delivery.ru/main/" & @CRLF & _
"http://www.bouquet-delivery.ru/main.php" & @CRLF & _
"http://www.bouquet-delivery.ru/main.html" & @CRLF & _
"http://www.bouquet-delivery.ru/main.htm"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")