re = /(?:index|home|main)(?:[\.\/](?:php|html?|\/?))?$/m
str = 'http://bouquet-delivery.ru/index.php
http://bouquet-delivery.ru/home
http://bouquet-delivery.ru/home/
http://www.bouquet-delivery.ru/
http://www.bouquet-delivery.ru/index.php
http://www.bouquet-delivery.ru/index.html
http://www.bouquet-delivery.ru/index.htm
http://www.bouquet-delivery.ru/index/
http://www.bouquet-delivery.ru/home
http://www.bouquet-delivery.ru/home/
http://www.bouquet-delivery.ru/home.php
http://www.bouquet-delivery.ru/home.html
http://www.bouquet-delivery.ru/home.htm
http://www.bouquet-delivery.ru/main
http://www.bouquet-delivery.ru/main/
http://www.bouquet-delivery.ru/main.php
http://www.bouquet-delivery.ru/main.html
http://www.bouquet-delivery.ru/main.htm'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end