import Foundation
let pattern = #"(?:index|home|main)(?:[\.\/](?:php|html?|\/?))?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
http://bouquet-delivery.ru/index.php
http://bouquet-delivery.ru/home
http://bouquet-delivery.ru/home/
http://www.bouquet-delivery.ru/
http://www.bouquet-delivery.ru/index.php
http://www.bouquet-delivery.ru/index.html
http://www.bouquet-delivery.ru/index.htm
http://www.bouquet-delivery.ru/index/
http://www.bouquet-delivery.ru/home
http://www.bouquet-delivery.ru/home/
http://www.bouquet-delivery.ru/home.php
http://www.bouquet-delivery.ru/home.html
http://www.bouquet-delivery.ru/home.htm
http://www.bouquet-delivery.ru/main
http://www.bouquet-delivery.ru/main/
http://www.bouquet-delivery.ru/main.php
http://www.bouquet-delivery.ru/main.html
http://www.bouquet-delivery.ru/main.htm
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)